Universal Access To All Knowledge
Home Donate | Store | Blog | FAQ | Jobs | Volunteer Positions | Contact | Bios | Forums | Projects | Terms, Privacy, & Copyright
Search: Advanced Search
Anonymous User (login or join us)
Upload

Reply to this post | Go Back
View Post [edit]

Poster: Matthew Watkins Date: May 23, 2014 8:24am
Forum: opensource_audio Subject: embedding images in item notes

For many of the items I've uploaded, I've included images in the notes, using simple HTML like
http://www.maths.ex.ac.uk/~mwatkins/imagery/ladychapel.jpg" alt="ladychapel.jpg" />

But in recent months(?) these have been automatically rewriting themselves as, e.g.
http://www.maths.ex.ac.uk/~mwatkins/imagery/ladychapel.jpg" alt="ladychapel.jpg" />

I have no idea why that prefix is appearing, but it means the images no longer display. Removing it doesn't help, it just reinstates itself automatically.

Does anyone know a way around this?

Reply to this post
Reply [edit]

Poster: Matthew Watkins Date: May 23, 2014 8:36am
Forum: opensource_audio Subject: Re: embedding images in item notes (correction)

First, I wrote "alt" where it should have been "src".

Secondly, my post isn't displaying correctly, as the prefix I was referring to has mysteriously removed itself, and there are a couple of 'broken image link' icons appearing.

So I'll try again, without the "<", ">":

Basically,

img src="http://www.maths.ex.ac.uk/~mwatkins/imagery/ladychapel.jpg"

keeps changing itself to

img src="//web.archive.org/web/2im_/http://www.maths.ex.ac.uk/~mwatkins/imagery/ladychapel.jpg"



Reply to this post
Reply [edit]

Poster: Administrator, Curator, or StaffJeff Kaplan Date: May 23, 2014 1:25pm
Forum: opensource_audio Subject: Re: embedding images in item notes (correction)

that redirects to http://empslocal.ex.ac.uk/people/staff/mrwatkin//imagery/ladychapel.jpg

if you go to http://empslocal.ex.ac.uk/people/staff/ you'll see that the child directories are not present. so our system attempts to find it in the wayback machine and ads web.archive.org

now if you go to the wayback url at http://web.archive.org/save/http://www.secamlocal.ex.ac.uk/people/staff/mrwatkin//imagery/ladychapel.jpg%22 you'll see that the site is blocked by robots.txt

Reply to this post
Reply [edit]

Poster: Matthew Watkins Date: May 23, 2014 4:01pm
Forum: opensource_audio Subject: Re: embedding images in item notes (correction)

Thanks.

I'm not in a position to change the robots.txt situation for this server. So is there any obvious way to resolve my problem (other than rehosting all of the images elsewhere and changing all of the links)?

Reply to this post
Reply [edit]

Poster: Administrator, Curator, or StaffJeff Kaplan Date: May 25, 2014 2:28pm
Forum: opensource_audio Subject: Re: embedding images in item notes (correction)

no. sorry.

Terms of Use (10 Mar 2001)